Redistribution d’une route statique sous OSPF.


Nous apprenons dans ce LAB  trois points importants :

  • L’implémentation du protocole OSPF sur les routeurs R1, R2 et R4.
  • Le principe de la redistribution des réseaux connectés à R2 sous OSPF
  • La redistribution au niveau du routeur R2 d’une route statique sous OSPF .

Nous supposons que tout les réseaux indiqués sur la Figure 6.1 utilisent le protocole OSPF sauf le réseau 10.2.3.0 /24 reliant R3 et R2. Nous supposons de plus que toutes les interfaces sont convenablement configurées. Nous avons introduit sur R2 une interface virtuelle – Loopback 2, d’adresse IP : 2.2.2.2 /24.

Implémentation OSPF sur R1, R2 et R4

Sur les routeurs R1, R2 et R4 on écrit en mode globale :

  • R1(config)#router ospf 1
  • R1(config)#network 10.1.2.0 0.0.0.255 area 0
  • R2(config)#router ospf 1
  • R2(config)#network 10.1.2.0 0.0.0.255 area 0
  • R2(config)#network 10.2.4.0 0.0.0.255 area 0
  • R4(config)#router ospf 1
  • R4(config)#network 10.2.4.0 0.0.0.255 area 0

La raison pour laquelle le routeur R3 n’arrive pas à faire un ping sur R1, R4 ou loopback2, c’est que dans la réalité R3 arrive toujours à atteindre R1, R4 et loopback2 grâce au routeur R2, c’est plutôt le chemin inverse de R1, R4 et loopback2 vers R3 qui cause un problème. Les routeurs R1, R4 et l’interface loopback2 ne connaissent pas R3 et n’ont pas de route par défaut pour l’atteindre. Le seul routeur ici qui connaît tout le monde , c’est le routeur R2.

La solution définie c’est de demander à ce dernier, routeur R2, de nous faire une redistribution de toutes les routes inconnues sur les routeurs R1 et R4 via le protocole OSPF – car R1-R2-R4 utilisent OSPF- Il est très important ici de comprendre cette notion de redistribution car elle reste générale pour tout autre protocole de routage.

Cette redistribution se fait sur le routeur R2 à l’aide de la commande :

  • R2(config)#router ospf 1
  • R2(config)#redistribute connected subnets

Notons que nous avons aussi implémenté une route statique par défaut : S* sur le routeur R1:

  • R1(config)#ip route 0.0.0.0 0.0.0.0 10.2.3.2

Tests ping R3- R1 et R3-loopback2 !!!!!

Remarque importante

Il est très importante d’assimiler ici cette notion générale de la redistribution : le routeur R2 redistribue ici via OSPF aux routeurs R1 et R4 tout les réseaux connectés à lui non connus par R1 et R4 – d’où le nom de connected subnets dans la commande redistribute -.

Pour finir ce LAB GNS3, nous allons simuler à l’aide d’une interface loopback3 une interface d’un réseau connectée au niveau du routeur R3. L’adresse IP loopback3 est choisie: 3.3.3.3 /24.

Au niveau du routeur R2, nous implémentons une route statique -S – pour atteindre cette interface loopback3. Soit :

  • R2(config)#ip route 3.3.3.0 255.255.255.0 10.2.3.3

Pour que R1et R4 puissent communiquer avec ce nouveau réseau ou cette interface loopback,, on effectue cette fois ci une redistribution statique via OSPF au niveau du routeur R2 de cette route statique sur l’ensemble des routeurs R1 et R4. Soit :

  • R2(config)#router ospf 1
  • R2(config)#redistribute static subnets

Un test ping de R1 sur Loopback 3 donne dans ce cas un succès !!!!!

 


 

 

LAB-Redistribution d’une route statique sous ospf

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *